Pulling my hair out

Tea bag

CB750 New member
Messages
2
Reaction score
0
Points
1
Location
Colchester.
Hoping someone here can offer me some direction, I have a k0 750sohc running f type carbs in a sidecar Motocross outfit I'm having hell n all trouble getting it to run right! The engine runs an electrexworld digital twin CDI ignition. And the fault seems to present like a fueling issue. All the carbs have been cleaned thougherly and re sealed new pumper diaphragm and floats. Float levels are correct and a plethora of jet combinations tried! Ticks over lovely revs to distruction but has a flat spot a mile wide between quarter and flat out. Run pure avgass in the tank. Any help would be appreciated! I'm suspicious the exhausts aren't helping but I'm a two stroke monkey so four popper exhausts are a dark art to me!
 

Attachments

  • IMG_20220607_131517.jpg
    IMG_20220607_131517.jpg
    243.9 KB · Views: 27

dirtdigger

Moderator
Staff member
Messages
3,343
Reaction score
59
Points
48
Location
Black Hawk SD
Why the Av gas? what engine mods? Carb boots in good shape with no vacuum leaks? Stock slides? stock needles? Better pic of the exhaust. Easiest way to see what it needs for fuel is to get to the troubled spot and start to close the choke....if it picks up then its lean, if it gets even worse than its rich. You can do this at various throttle openings to see how close the jetting is.
 

Tea bag

CB750 New member
Messages
2
Reaction score
0
Points
1
Location
Colchester.
Because pump fuel is so poor! Bog standard motor bog standard carbs jetted up! Tried choking it in several positions wich helps to a point but going from a 125 main to a 130 then overfuels! All the boots and seals are brand new there's no unmetered air getting in!
 

dirtdigger

Moderator
Staff member
Messages
3,343
Reaction score
59
Points
48
Location
Black Hawk SD
So you havent done any needle shimming? If choke helps then its still lean in those areas. What are the spark plugs looking like? Timing set to stock spec? Ignition advancer working and working correct? Exhaust will still play a part in how it runs. Is engine in good shape with good compression? I know its going to run different on AV gas and have never run it so I dont know its tendencies but unless you have high compression its not really necessary but thats up to whatever you want to run.
 

Scootch

CB750 Member
Messages
17
Reaction score
4
Points
3
Location
Niagara County, NY
Are the carb cables adjusted properly at the carb tops?
Are the mixture screws set properly?
Are the idle screws set properly?
Do the carb slides open and close together?
Do the carb slides bottom at the idle screw simultaneously?
Have you synced the carbs?
Do you have vacuum leaks?
Do you have vacuum leaks where the carb sync ports are on the carbs? Those can be stripped and not sealing properly.
 
Top