After Rebuild ALL 4 Carbs Overflowing

Daddyoo

CB750 Member
Messages
7
Reaction score
0
Points
1
Location
North Carolina
I have a 1977 CB750F Super Sport that was purchased few months back that sat for 2 years. It ran, but barely. Carbs did not leak at all before I started this project. I pulled the carbs and rebuilt with them. I was meticulous about keeping each carburetor pieces and parts including the floats marked containers for each carb. After rebuild, I put it back together and with new float needle and overflow tube leaked on all 4. I put the old float needles back in and had same overflow issue. I then cleaned each the float seats on the carb (with 000 steel wool) now looks like new inside each of the float seats. Reassembled again with the new float needles that came in kit. I used a float guide this time adjusting floats all to 14.5 MM (may not be perfect but pretty dam close) the floats move extremely freely nothing binding on float mechanism. I tested the float seats and seals by putting a rubber band around float testing each cab separately, they all seal perfectly when it is apart on the bench. I reassembled with same result gas coming from overflow tube. Carb 1,2 and 3 leak with bike on the kick stand if I sit the bike up carb 4 start to leak also. I tapped the carbs with the wrench and they still leak.

Is there something I am missing? The rubber mounts the carb attaches to the engine block were removed. Wondering if they somehow are not in the correct position making the carb sit high enough? How do I tell if the carbs are stitting at the correct height on the bike?

ANY HELP would be greatly appreciated.
 

Daddyoo

CB750 Member
Messages
7
Reaction score
0
Points
1
Location
North Carolina
I found the problem... The drain screws on the bowls were loose after I put new washers in them I did not tighten all the way. Simple mistake that made me focus on float valves when it had nothing to do with it...
 

PensylDJ

CB750 Member
Messages
5
Reaction score
0
Points
1
Location
Djn1661549
Darn. I was hoping to figure my problem out. I have the same problem with my carbs. I rebuilt them. But didn't change the floats.
 
Top