Results 1 to 6 of 6
  1. #1
    CB750 Member kvikgrip68's Avatar
    Join Date
    Aug 2018
    Location
    Denmark
    Posts
    10

    Lack of Oil pressure 750 K7

    Hi there

    Have a K7 from 77

    Bike hasnt been running since 1990

    Everything cleaned up

    New oil , filter , battery , sump cleaned

    Starter runs fine and motor fires up fine - good compression - has 40000 km on the clock

    Problem is that engine oil lamp doesnt turn off when running

    I have checked oil pressure relief valve in the sump and its ok

    I have tried to fill oil in top off engine through valve adjustning holes and reservoir oil tank is full of oil .

    the 2 Oil hoses from oil tank to crankcase is checked ok

    No oil comes to Oil filter house

    When oil pan is dropped lots of oil comes out

    Anyone with any ideas in this matter ?

  2. #2
    CB750 Addict dan1951's Avatar
    Join Date
    Sep 2013
    Location
    armada mi. 48005
    Posts
    326
    First off do not fill the engine with oil in the valve caps. The engine is a dry sump meaning the oil is stored in the oil tank not the oil pan when started the oil is fed from tank to the engine oiling circuit via oil pump. I believe there is a check valve to keep the oil in the tank when not running ( Not positive on My part) I would install a oil pressure gauge instead of the idiot light switch. The switch could be permanently grounded leaving the light on all the time. Good luck with it sorry I can not be of more help.

  3. #3
    Moderator dirtdigger's Avatar
    Join Date
    Feb 2012
    Location
    Black Hawk SD
    Posts
    2,650
    Sometimes the pumps get air lock when no oil in them for years or if you have had the pump apart and didnt prime it. You may have to pull the pump and put it in a tube of engine oil and turn the gear to get the air pocket out then reinstall on motor. You can first try pulling the hoses off the tank and feed oil into the suction hose then bump the motor over and keep adding oil as the level goes down till you get oil out of the return line. You may want to do this with the oil filter off then as soon as you get oil put it back on and continue. Ideally you would rig up a tank of pressurized oil and pressurize the engine in the oil gallery beings it is dry, if you crank much with no oil pressure you will damage engine bearings.

  4. #4
    CB750 Member kvikgrip68's Avatar
    Join Date
    Aug 2018
    Location
    Denmark
    Posts
    10
    Quote Originally Posted by dirtdigger View Post
    Sometimes the pumps get air lock when no oil in them for years or if you have had the pump apart and didnt prime it. You may have to pull the pump and put it in a tube of engine oil and turn the gear to get the air pocket out then reinstall on motor. You can first try pulling the hoses off the tank and feed oil into the suction hose then bump the motor over and keep adding oil as the level goes down till you get oil out of the return line. You may want to do this with the oil filter off then as soon as you get oil put it back on and continue. Ideally you would rig up a tank of pressurized oil and pressurize the engine in the oil gallery beings it is dry, if you crank much with no oil pressure you will damage engine bearings.
    thanks for helping - so i can take off oilfilter and see if oil gets out off hole there when cranking ? i have now decided to put on a new oil pressure switch also

    i did try to crank motor with sump pan off watching the oil pump with eyes onhe pump …. it looks like it sucks cause it was dripping out off the oil pump Bottom filter with oil there after cranking

  5. #5
    Moderator dirtdigger's Avatar
    Join Date
    Feb 2012
    Location
    Black Hawk SD
    Posts
    2,650
    The oil pump has two sections....two pumps in one. The 750 is dry sump so it has a scavange pump that pumps oil out of the pan up to the oil tank then it has a high pressure pump that sucks out of the tank and pressurizes the engine.

  6. #6
    CB750 Member kvikgrip68's Avatar
    Join Date
    Aug 2018
    Location
    Denmark
    Posts
    10

    Still no pressure

    Quote Originally Posted by dirtdigger View Post
    The oil pump has two sections....two pumps in one. The 750 is dry sump so it has a scavange pump that pumps oil out of the pan up to the oil tank then it has a high pressure pump that sucks out of the tank and pressurizes the engine.


    Hi All
    Back Again
    Still no pressure on oil …..lamp wont go off

    New oil pressure switch
    Tried everything with oil directly into oil gallery plug and pressurized air in oil tank
    Theres oil at the oil filter when i check there
    checked the wire from the oil switch is okay
    checked valves is not sticky in pump

    what to do now ? other than putting on a new oil pump ?

Similar Threads

  1. low oil pressure at idle
    By scully39 in forum Engine / Exhaust
    Replies: 2
    Last Post: 09-02-2016, 05:42 PM
  2. oil pressure stop light. help!
    By Staubig in forum The DOHC Garage (1979-1983)
    Replies: 2
    Last Post: 05-26-2016, 10:36 PM
  3. Oil Pressure
    By Spaceman49 in forum The CB750 Garage
    Replies: 5
    Last Post: 04-02-2014, 11:05 AM
  4. Oil Pressure Gage
    By Vicman in forum The SOHC Garage (1969-1978)
    Replies: 14
    Last Post: 10-25-2013, 08:24 AM
  5. Lack of power
    By oldman in forum The CB750 Garage
    Replies: 1
    Last Post: 06-15-2013, 12:25 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •