Results 1 to 15 of 15

Thread: Sprung a leak

  1. #1
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136

    Sprung a leak

    I pulled into work. I noticed fuel leaking from the end of the closed carb? Any ideas where. I dont have many tools on hand.

    Sent from my SM-A520W using Tapatalk

  2. #2
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136
    Only 1 carb is leaking. The 3rd one from left. I am guessing float problem

    Sent from my SM-A520W using Tapatalk

  3. #3
    Old Bike Nerd grepper's Avatar
    Join Date
    Oct 2012
    Location
    Lowell, MI
    Posts
    438
    Quote Originally Posted by Skelee View Post
    Only 1 carb is leaking. The 3rd one from left. I am guessing float problem
    Most Likely,
    you can try the carb drain screw and wash out what ever is obstructing the float valve from closing all the way. I've had that work. Or tap the carb with the handle of a screw diver, that might stop the leak. Or, just use the petcock to turn off the gas till you can get to cleaning the carbs.
    Drive fast and take chances

  4. #4
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136
    The carbs have no drain hoses. Should i add some?

    Sent from my SM-A520W using Tapatalk

  5. #5
    Old Bike Nerd grepper's Avatar
    Join Date
    Oct 2012
    Location
    Lowell, MI
    Posts
    438
    Quote Originally Posted by Skelee View Post
    The carbs have no drain hoses. Should i add some?
    That's up to you, that or a dish or rag to keep from making a mess.



    Sent from my XT1254 using Tapatalk
    Drive fast and take chances

  6. #6
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136
    https://youtu.be/LnL8oYWAcbI

    Sent from my SM-A520W using Tapatalk

  7. #7
    Old Bike Nerd grepper's Avatar
    Join Date
    Oct 2012
    Location
    Lowell, MI
    Posts
    438
    Yup, looks like the float valve is not sealing. Could be some junk in there keeping it from sealing, the seat or needle has corrosion, or you could have a hole in your float, keeping it from floating.
    Drive fast and take chances

  8. #8
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136
    Finally took carbs out. Gave them good cleaning. No longer leak. However. Hell of a time getting the air box side all connected. I tried everything i know. Any suggestions i looked at youtube and noyhing works for me.

    Sent from my SM-A520W using Tapatalk

  9. #9
    CB750 Addict Wez_'s Avatar
    Join Date
    Apr 2017
    Location
    Enfield, CT
    Posts
    283
    What's preventing it from going on?

  10. #10
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136
    I cant seem to get them on, the slip off on side or i get one side only. I sprayed wd40. I moved air box back.

    Sent from my SM-A520W using Tapatalk

  11. #11
    Old Bike Nerd grepper's Avatar
    Join Date
    Oct 2012
    Location
    Lowell, MI
    Posts
    438
    They are a bitch to get on. I Actually ended up using a ratchet strap around the back of the air box, all the way around the engine to get them on.
    Drive fast and take chances

  12. #12
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136
    I gave up. Took bike to shop. See how much i get hosed for

    Sent from my SM-A520W using Tapatalk

  13. #13
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136
    back on the rode!

    Sent from my SM-A520W using Tapatalk

  14. #14
    CB750 Member MotersickleBum's Avatar
    Join Date
    Nov 2018
    Location
    Florida
    Posts
    27
    Quote Originally Posted by Skelee View Post
    I gave up. Took bike to shop. See how much i get hosed for

    Sent from my SM-A520W using Tapatalk
    i'm deeply disappointed in you, son...

  15. #15
    CB750 Addict Skelee's Avatar
    Join Date
    Nov 2017
    Location
    Hamilton, Canada
    Posts
    136
    After quote from shop. I fixed it myself!
    I used ratchet straps to help hold things and slow got it!


    Sent from my SM-A520W using Tapatalk

Similar Threads

  1. Oil Leak?
    By burnsie in forum General Motorcycle Discussion
    Replies: 8
    Last Post: 06-02-2017, 09:16 PM
  2. oil leak
    By Coxy in forum Engine / Exhaust
    Replies: 7
    Last Post: 05-03-2017, 12:44 AM
  3. Carb leak, Help!
    By sellsme in forum The SOHC Garage (1969-1978)
    Replies: 2
    Last Post: 09-29-2014, 03:01 PM
  4. Oil leak
    By greenmachine in forum The SOHC Garage (1969-1978)
    Replies: 2
    Last Post: 06-12-2014, 05:04 AM
  5. Oil pan leak, help
    By Brdeca in forum The CB750 Garage
    Replies: 1
    Last Post: 07-27-2013, 03:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •