Results 1 to 3 of 3
  1. #1
    CB750 Member nighthawking's Avatar
    Join Date
    Sep 2013
    Location
    Longwood, FL
    Posts
    7

    Right front turn signal on

    Anybody seen this? When I turn the key on to start, the right front turn signal comes on and stays on. All turn signals work when activated, brake lights work fine. When key is in park, turn signal is off. Low mileage bike, very clean. Any ideas? Thanks.

  2. #2
    CB750 Enthusiast kal-el428's Avatar
    Join Date
    Jan 2013
    Location
    Waterford, MI
    Posts
    71
    This wont be much help, but mine does the same thing.
    1976 CB750F

  3. #3
    CB750 Member nighthawking's Avatar
    Join Date
    Sep 2013
    Location
    Longwood, FL
    Posts
    7
    Turns out both left and right front turn signals are supposed to be half on for running lights. It was actually the left bulb that was half out. Replaced it, and things are normal. Both on when the key is on.

Similar Threads

  1. Can't Get My Bike To Turn Over
    By Midwest750 in forum The CB750 Garage
    Replies: 7
    Last Post: 09-01-2013, 11:57 PM
  2. Non LED Turn Signals Not Blinking
    By jacksondee in forum Electrical
    Replies: 1
    Last Post: 07-29-2013, 06:21 PM
  3. Turn signals are not blinking
    By jays-cb750 in forum Electrical
    Replies: 4
    Last Post: 04-20-2013, 05:27 AM
  4. 1979 model won't turn over
    By Bcoggin in forum The CB750 Garage
    Replies: 8
    Last Post: 01-10-2013, 04:04 PM
  5. For Sale - Clear stock style turn signal lenses with orange bulbs Any interest?
    By Andersons in forum Classifieds
    Replies: 0
    Last Post: 07-30-2012, 08:09 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •