• CB750.com is dedicated to the Honda CB750 SOHC and DOHC motorcycles and to their owners who love to ride, restore, and customize them.  All CB750 enthusiasts are welcome regardless of where you are from or whether you are into CB750 choppers, bobbers, cafe racers, drag bikes, or restorations.  Enjoy the site!
  • September $50 Gift Certificate Giveaway from CB750 Supply

    June 2012 CB750 Supply $50 giveaway The September CB750 Supply $50 gift certificate giveaway is up and running! Entries will be accepted until September 30th at 1:00PM EST and shortly after a winner will be randomly chosen.

    Enter the drawing!

  • Recent Forum Posts

    amc49

    'Lead' not 'head', the black ignition power wire you said before had power. You used the word yourself..........

    'Did test the black "key

    turn signals not working

    amc49 Today, 05:28 PM Go to last post
    nightengale

    With key on, oil pressure and "head" (whatever that is supposed to mean) have no power. Turn signals, tail and horn do have power. Nothing gets

    turn signals not working

    nightengale Today, 04:48 PM Go to last post
    Springer2

    Thanks for the link. I would be very happy with the stock carbs we have now as they are setup for the Automatic. Our issue is the bad manifolds and we

    New Member with a Project CB750A Automatic

    Springer2 Today, 04:23 PM Go to last post
    amc49

    Recent from our resident SOHC guy 'dirtdigger'......maybe helpful.

    http://www.cb750.com/threads/6205-Hondamatic-carb-swap

    New Member with a Project CB750A Automatic

    amc49 Today, 04:07 PM Go to last post
    amc49

    Black ignition lead having power with key on says all fuses should have power to them, do they? If so the neutral and oil lights should be on at key on,

    turn signals not working

    amc49 Today, 03:50 PM Go to last post
    nightengale

    Installed a used voltage regulator (purchased from a cycle supply - I'm assuming it's good). Still have no power, no dash lights, etc., however, in Park

    turn signals not working

    nightengale Today, 02:10 PM Go to last post